[Mailman-Users] Apache does not have permission to accesspipermail/listname

Mark Sapiro mark at msapiro.net
Mon Apr 13 21:07:49 CEST 2009

Lars Olson wrote:

>I am receiving an apache forbidden page when I try to access my archives
>after moving my lists to a new server.  My old server was 2.1.8 – new server
>is running 2.1.9 and using the same domain name.
>Everything is working correctly except the archives... 
>/etc/httpd/conf.d/mailman.conf has appropriate piper alias
>--- cut here ---
>Alias /pipermail/ /var/lib/mailman/archives/public/
><Directory /var/lib/mailman/archives/public>
>    Options Indexes MultiViews FollowSymLinks
>    AllowOverride None
>    Order allow,deny
>    Allow from all
>--- end cut here ---
>- Permissions on public archives directory is drwxrwsr-x with symlinks to
>private lists
>- Permissions on private archives directory is drwxrws--x with directories

That's good.

>below as drwxrwsr-x
>- Files within the private folder are world readable with -rw-rw-r--
>- I ran the bin/arch script (/usr/lib/mailman/bin/arch listname
>- I ran the withlist script to verify permissions are correct (./withlist -l
>-r fix_url listname)

It's bin/check_perms that checks permissions. fix_url changes web and
email host names for the list which chouldn't be necessary in your

>Don't know what else to try.  Haven't found anything in the FAQ or the
>Mailman archives.  I have tried reading the documentation labyrinth but that
>hasn't helped so far - I'm thinking I need a new direction, a new path to
>follow - been looking at this too long... 
>Looking for some help at this point.

What is the error message in Apache's error_log?

Is this a SELinux or other security manager issue?

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list