[Mailman-Users] Mailman 2.1.12 - Python 2.4.[456]incompatibility

Mark Sapiro mark at msapiro.net
Thu Apr 23 23:29:38 CEST 2009

Barry Finkel wrote:
>My Python version is 2.4.3, and I ran a modified conftest.py program
>from the configure script to determine that the email package is 3.0.1.
>I could not determine the package  version number from looking at the
>.py modules in /usr/lib/python2.4/email on my Ubuntu Mailman machine.

A normal ./configure, make install of Mailman 2.1.12 should work with
Python 2.4.3/email 3.0.1 without any additional patches.

There are at least two ways to directly determine the email package
version in a Python installation:

[mark at sbh16 ~]$ grep version /usr/lib/python2.4/email/__init__.py
__version__ = '3.0.1'
[mark at sbh16 ~]$ python
Python 2.4.3 (#1, Mar 14 2007, 18:51:08)
[GCC 4.1.1 20070105 (Red Hat 4.1.1-52)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import email
>>> email.__version__
[mark at sbh16 ~]$

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list