[Mailman-Users] Error running bin/mailmanctl restart

Paul Kleeberg paul at FPEN.ORG
Thu Dec 17 15:20:32 CET 2009

Mark has been helping me with this off-line but I thought I would send this to the list to see if there are others who are aware of the solution.  I have been using the following on a clean install of Mac Server 10.5.8 and upgrading Mailman 2.1.9 to 2.1.12:

	./configure --prefix=/usr/share/mailman --with-cgi-gid=_www --with-mail-gid=mail --with-mailhost=domain.com --with-urlhost=domain.com --with-var-prefix=/var/mailman  --with-groupname=_mailman

and get the following error:

	***** Installation directory /var/mailman is not configured properly!
	***** Directory must be owned by group _mailman: /var/mailman 

/var/mailman is has the settings root:wheel while the files inside are root:_mailman.

Do I need to change the group of the /var/mailman directory for the install?  I know that change is probably not significant, but I an not sure enough of my knowledge to know.

Once I get this right, I plan on upgrading a 10.6.2 production server running 2.1.12rc1 to 2.1.12.


Paul Kleeberg
paul at fpen.org

On Dec 16, 2009, at 3:53 PM, Mark Sapiro wrote:

> Paul Kleeberg wrote:
>> You are correct.  /var points to /private/var but /private/var/mailman
>> is owned by root:wheel.  Should I chgrp to _mailman which is the group
>> of all the files inside or use
>> --with-groupname=wheel
> As long as the subordinate directories are all group _mailman and
> SETGID, the group of var-prefix itself doesn't matter.
> And you should configure with --with-groupname=_mailman to match the
> group of the existing install.

More information about the Mailman-Users mailing list