[Mailman-Users] MMDSR Question

Jeff Grossman jeffg at turners.com
Sun Feb 15 18:06:47 CET 2009

Brad Knowles wrote:
> on 2/14/09 10:49 AM, Jeff Grossman said:
>>                                 I have not been able to find any answers
>> via Google or the mailing list archives.  I have set up all of the
>> parameters, but the program never finishes running.  When I run it from
>> the command line, it never returns the command line, just continues
>> running forever.  Any help would be appreciated.  I am running this on
>> an OS X 10.3.9 machine.  The temp file that it creates gets as far as:
> I never tried to run the script on a MacOS X machine.  On the Linux and
> FreeBSD machines where I run it (including the server for python.org,
> where this list is hosted), I don't see these kinds of problems.
> Have you tried adding a "-vx" option on the first line of the script, so
> that you can see each and every line of the code as it is executed?
No, I never tried the "-vx" option, actually I don't really know where I
would run that.

But, I did figure out my problem.  I decided to look over the script line
by line.  And, when I came to the line write after the "Other Errors"
section it was cut with a bunch of line feeds.  I removed the line feeds
and now it works correctly.  For some reason pico must be splitting that
line when it saves it.  Here is the line in question:

            $EGREP -vi '(Uncaught runner exception|No such
list|Traceback|shunting)' $TMPLOG | $SED -e 's/^.* ([0-9]*)
//' -e 's/unparseable message.*/unparseable message/' -e
's/preserving file.*/preserving file/' | $SORT | $UNIQ -c |
$SORT -nr >> $TMP

It was cutting the variable $TMPLOG with line feeds.

Thanks for your help.  Everything in regards to MMDSR is now working


More information about the Mailman-Users mailing list