[Mailman-Users] Unable to open list admin page

Mark Sapiro mark at msapiro.net
Wed Feb 25 23:52:57 CET 2009

Max Pyziur wrote:
>We have one list with several thousand emails. We wanted to see if we could 
>find and remove those email addresses that have gotten stale or invalid. 
>Consequently, we adjusted the bounce processing settings.
>Now, we can't log in to that particular list's admin page (all other lists do 
>no have this problem). After typing the password and hitting enter, the web 
>browser appears to be authenticating, but after an extensive period shows a 
>message to the effect "Internal Server Error."
>It seems that this would indicate some sort of corrupted file or data.

Can you go to the listinfo page for the list, or do you get the came

What is the error message in the web server logs. If it is "premature
end of script headers", the CGI is timing out before issuing any

The issue could be a corrupt lists/LISTNAME/config.pck, but I think it
is more likely a stale lock. See the FAQ at
<http://wiki.list.org/x/noA9>. If you find a stale lock, check
Mailman's locks and error logs for clues as to what may have caused

Note that in 2.1.5, there is a potential issue with reducing
bounce_score_threshold in that cron/disabled doesn't check if bounce
info is stale so, e.g, if a member has stale bounce info with a score
of 3.0 and you reduce bounce_score_threshold from something greater
than 3 to something <= 3, the next time cron/disabled runs, that
member's delivery will be disabled. This was fixed in 2.1.10.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list