[Mailman-Users] Warnings from senddigests

Jesper Dybdal jd-mailman-users at dybdal.dk
Sat Jan 3 18:45:40 CET 2009

On Sat, 03 Jan 2009 00:51:33 +0100, I wrote:

>I currently have to digest subscribers, so I don't know if this a real

That should have been "*no* digest subscribers" - sorry.

On Sat, 3 Jan 2009 08:51:10 -0800, Mark Sapiro <mark at msapiro.net> wrote:

>Mailman 2.1.11 is not compatible with Python 2.6. Most of the errors
>are deprecation warnings similar to those above and also involving
>hashlib. You'll probably find lots more in Mailman's error log.

Now I'm confused.  Why do you think I am using Python 2.6?

I am actually using Python 2.4.5 (installed using the Slackware 11.0
Python package):

>jesper at nuser:~$ python -V
>Python 2.4.5

And yes, there are quite a few of those warnings in the error log.
Mailman seems to work in general, but I haven't tried digests - which
probably do not work, given the error message.

But everything I've read seems to indicate that Python 2.4.5 should be
fine for Mailman.

I've installed Mailman straight from the 2.1.11 distribution, except for
a Postfix VERP patch and some file rights changes to make it run with

It runs on a Slackware 11.0 Linux with some packages upgraded from
source or from Slackware upgrades.  The kernel is Linux
Jesper Dybdal, Denmark.
http://www.dybdal.dk (in Danish).

More information about the Mailman-Users mailing list