[Mailman-Users] Mailman receives, archives, acks message but does not send to list

Wei Qin wqin.work at gmail.com
Fri Jan 16 07:48:47 CET 2009

Brad Knowles wrote:
 > Wei Qin wrote:
 >> The server was set up a year ago and has been functioning properly.
 >> But recently it no longer broadcasts to the list. The smtp log only
 >> shows the acknowledgement message, but no multi-recipient broadcasting
 >> message. Can anyone give a clue?
 > Search the Mailman FAQ Wiki for "troubleshooting".

Thanks. I tried everything on the page 

but nothing helps. Permission is correct. The qrunners and the MTA are 
all up and running. Log shows that it is sending out acknowledgements, 
auto responses, and daily digests fine, but it somehow skips sending the 
message itself.

I tried to strace the outgoingrunner, it does the following when a 
message is posted.
1. opens the message file in the out folder,
2. opens config.pck,
3. opens another message file in the out folder (seems user notification)
4. opens config.pck again,
5. establish socket connection and sends a message.

Apparently, it skips sending the original message file after reading 
config.pck. I went through the configuration options but couldn't see 
any option that could have turned off message delivery. What could have 
gone wrong?



More information about the Mailman-Users mailing list