[Mailman-Users] Password reminder on private archive login page

liste yoneticisi listeyon at metu.edu.tr
Mon Jul 20 12:26:18 CEST 2009


I have two main questions.

First; We once asked about adding password reminder to private archive
login page. We tried some modifications but couldn't succeed. I copied the
previous correspondence below.

>Can I put the password reminder on private archive login page? So that,
>list members who want to see the archive, but do not remember their
>passwords, can quickly learn their passwords. Otherwise, password
>reminder is too hard to find using the links on general list info page..

This is a good idea. I think I'll implement it for Mailman 2.2.

What needs to be done is the reminder button has to be added to the
private.html archive login template and code needs to be added to
Mailman/Cgi/private.py to recognize the button and send the reminder.

You can look at Mailman/Cgi/options.py for how it's done there.

I have added the following lines to

        print Utils.maketext(
            {'action'  : Utils.websafe(action),
             'realname': mlist.real_name,
             'message' : message,
             }, mlist=mlist)

### My Lines 7/4/2009 Eklenti baslangic

    if cgidata.has_key('emailpw'):
            mlist, doc, user, cpuser, userlang,
            _('A reminder of your password has been emailed to you.'))
        print doc.Format()
### My Lines 7/4/2009 Eklenti bitis

    lang = mlist.getMemberLanguage(username)

    # Authorization confirmed... output the desired file
        ctype, enc = guess_type(path, strict=0)


But nothing changed.:-(

What else can we do about it?
Mailman version is 2.1.9


The second question is about vesion upgrade.

Mailman, in our system, is running on Debian.
Python version is 2.4.4

I heard that 2.1.12 doesn't work properly on 2.4.4 but I am informed that
the newer version of Python  doesn't exist on Debian Package.
It seems difficult to upgrade under these circumstances.

What are the major differences between the Mailman versions 2.1.9 and
2.1.12 with regard to security, usability?


More information about the Mailman-Users mailing list