[Mailman-Users] What causes "decoding Unicode is not supported"?

Rosenbaum, Larry M. rosenbaumlm at ornl.gov
Wed Sep 2 15:05:36 CEST 2009

> From: Mark Sapiro [mailto:mark at msapiro.net]
> Rosenbaum, Larry M. wrote:
> >We are running Mailman 2.1.12 on Solaris 9 SPARC, Python 2.4.2. What
> causes the following "decoding Unicode is not supported" error message?
> I've looked at digest.mbox and didn't find any Unicode.
> [...]
> >Your "cron" job on ornl71
> >/usr/local/bin/python -S /usr/local/mailman/cron/senddigests
> >
> >produced the following output:
> >
> >List: dcaplusplus: problem processing
> /usr/local/mailman/lists/dcaplusplus/digest.mbox:
> >decoding Unicode is not supported
> I think this may be the "Mailman 2.1.12 is not compatible with python
> 2.4.x (x>3)" issue. See the March 2009 note at the end of the FAQ at
> <http://wiki.list.org/x/pYA9>.

My original message was incorrect (I was looking at the wrong system).  The system generating the error message is running python 2.5, which is stated as one of the recommended Python versions.  What else can I check?

Thanks, L

> --
> Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
> San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list