[Mailman-Users] Problem with inappropriate breaks in messages

Chris Malme cim2009 at malme.co.uk
Tue Apr 20 11:14:05 CEST 2010

Hi all,

Newbie here.

I have recently moved a list over to Mailman running under Plesk on a VPS.
The version of Mailman that I currently have access to is 2.1.9.

I had a mbox file to import from my old mail-list system. Originally, I had
some problems - the mbox file was large (7 years of archives) and some
messages had a literal "\nFrom ", which cause the archiver to break the
messages inappropriately. For the moment, I escaped these incidents with a
>, although that now means that ">From " appears in the archive, but I
thought it was better than having a corrupted archive, and I could rebuild
at a later date when I fully understood how Mailman copes with this.

However, I have very quickly discovered that if a post to the list contains
- in the actual message text - a newline (a single newline, not a double)
followed by the word From, Mailman interprets that as a new message and
breaks the message at that point, creating a fragment message with no
subject line.

Note that this is not just the archive - this actually affects messages
being sent to the subscribers - i.e. a message containing a newline followed
by "From " will be split in two before going out.

This really surprised me, as it is not at all unlikely that sometime or
other someone will post "From " at the start of a line!

Is this a known bug (I did search, and couldn't spot anything), and is it
fixed in other versions? Or do I have a rogue version of Mailman installed
on my VPS? The behaviour is consistent and repeatable.



More information about the Mailman-Users mailing list