[Mailman-Users] The Dreaded Group Mismatch Error

LuKreme kremels at kreme.com
Sat Apr 24 22:27:29 CEST 2010

On 24-Apr-2010, at 13:15, Mark Sapiro wrote:
> LuKreme wrote:
>> I tried to send a message to a low-traffic announce-list which failed:
> Are other lists working?

No, everything is dead.


[Let's just ignore anything having to do with the ports package, I'm trying to get the source tarball to work]

>> So, I went and grabbed the source and read up on <http://www.gnu.org/software/mailman/mailman-install/node7.html>
>> ~/src/mailman-2.1.13 $ ./configure --with-username=nobody --with-mail-gid=nobody --with-group-name=nobody
>> configure: WARNING: you should use --build, --host, --target
> This is very strange. When I run the above command in a freshly
> unpacked 2.1.13 tarball directory (with 2.5 python), I get:
> [msapiro at msapiro ...2.1.13/mailman-2.1.13]$ ./configure
> --with-username=nobody --with-mail-gid=nobody --with-group-name=nobody
> configure: WARNING: unrecognized options: --with-group-name
>      Because it's spelled --with-groupname

Yeah, I don't get that.

# python --version
Python 2.5.5
# bash --version
GNU bash, version 4.0.35(0)-release (i386-portbld-freebsd6.2)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

This is free software; you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

> checking for --with-python... no

No idea, python is certainly installed.

> Could there be something in your environment that's affecting this? Or
> your shell? What shell is invoked by /bin/sh?

running straight bash, nothing set in my environment. In fact, I tried to compile it just now with su root (no .profile or .bashrc active at all).

>> and even if you try to make at that point, there is no Makefile
> Are you saying configure completes and makes a config.status and runs
> that and there is no Makefile after that? Really strange…

Yes, exactly.

I've downloaded the tarball twice now.

> Note that the expected group (mailman) is compiled into the
> mailman/mail/mailman wrapper (from configure's --with-mail-gid) in
> standard Mailman. I don't know how to set it in your package.

I keep trying to get it to work properly with the mailman user and group but it is not playing nice. I would prefer, of course, to have this all working properly (with uid and gid of mailman) but working -at all- would be better.

I'm going to try and recompile the port with mailman/mailman and split the aliases out into the data/aliases file, set those perms, re-postalias all the files, wave a fresh chicken bone over the server, and hope for the best.

Eyes the shady night has shut/Cannot see the record cut And silence sounds no
worse than cheers/After earth has stopped the ears.

More information about the Mailman-Users mailing list