[Mailman-Users] Mailman and htdig - issues after installing htdig

Scott Race scott at 916networks.com
Fri Aug 20 19:48:52 CEST 2010

I am running Mailman 2.1.13 on a new server (no live lists yet), server OS is RHEL5.
I have one test list configured and was working fine before installing htdig 3.2.0b6.

Applied both the indexing (444879) patch followed by the htdig (444884) patch to my 2.1.13 source directory, ran ./configure --with-cgi-gid=apache (as my install complains if I do not), then make and make install.

First issue - after doing this, I am unable to post new messages to my test list.  I see the email comes into the server via maillog log, but no post, nothing in mailq.  Nothing is /mailman/logs/error either. Not sure where it's going.

Second - htdig seems like it's almost there, but when I run a search, I get:

htsearch detected an error. 

Unable to read word database file '/usr/local/mailman/archives/private/mailman_project/htdig/db.words.db'
Did you run htdig?

I'm assuming I just need to run /usr/bin/rundig, which I have.  Checkd the permissions against a post Mark had a little while back, mailman:mailman is what my db directory and files are set to.

htsearch returns same error above from command line (about did you run htdig). 

Rebooted server just to see, no effect.

Ran /cron/nightly_htdig -v mailman_project and it actually worked, returned:
htdig'ing archive of list: mailman_project

now, only problem is when I do a search - it returns a blank page.

Thanks in advance for anyone's help, been working on this for awhile and feel like I'm pretty close.

More information about the Mailman-Users mailing list