[Mailman-Users] Mailman list sends but doesn't receive mail.

JRC Groups joemailgroups at gmail.com
Fri Dec 10 07:47:47 CET 2010


Again, I can't thank you enough. The list(s) are up and running. I wouldn't
have been able to get it to work had it not been for your help.

I also want to thank those who responded either through the list or
privately with helpful answers to my Unix-related questions. Your answers
have helped me find my way around Unix and motivated me to further improve
my understanding of it.

There are a few things I still need to tweak and I thought I would ask you a
few additional questions. I hope you don't mind.

Question 1.

I have created two additional lists for a total of three that I created plus
one that Apple's own Server Admin requires (a list named Mailman). Using the
web interface to check the lists hosted by my domain I find conflicting
results. This is what I have:


List                        Description
List 1                      [no description available]
List 2                      [no description available]


List                        Description
List 3                      [no description available]
List 4                      [no description available]

Shouldn't both www.domain.com and domain.com lead to the same results ? How
can I make the necessary corrections so that both addresses are
interchangeable and lead to the same results ?

Question 2.

As I made an attempt to create lists using the Mailman's web interface
instead of Apple's Server Admin I couldn't get it done. Mailman kept
returning an error message stating I didn't have permission to create lists.
I tried numerous different passwords including the admin password for my
server but it wouldn't work.

What have I done wrong ?

Thank you again for all your help.


On 12/8/10 6:07 PM, "Mark Sapiro" <mark at msapiro.net> wrote:

> JRC Groups wrote:
>> I sent the message and this is what the log in Server Admin shows:
>> Dec  8 17:48:13 dentserv postfix/smtpd[37996]: NOQUEUE: reject: RCPT from
>> mail-gw0-f52.google.com[]: 450 4.7.1
>> <Implants-request at 3wforum.com>: Recipient address rejected: Service is
>> unavailable; from=<joemailgroups at gmail.com>
>> to=<Implants-request at 3wforum.com> proto=ESMTP helo=<mail-gw0-f52.google.com>
>> Dec  8 17:48:13 dentserv postfix/smtpd[37996]: disconnect from
>> mail-gw0-f52.google.com[]
> This is Apple Postfix's greylisting at work. googlemail should retry
> the send after a few minutes and it should succeed. See, e.g.,
> <http://discussions.apple.com/message.jspa?messageID=10151235>.
>>> Try running
>>>   sudo /usr/share/mailman/bin/check_perms -f
>>> If it runs cleanly (don't worry about the warning about
>>> archives/private being world searchable) logging and archiving should
>>> work.
>> I ran it and the following is the output:
>> dentserv:~ locadmin$ sudo /usr/share/mailman/bin/check_perms -f
>> Password:
>> Warning: Private archive directory is other-executable (o+x).
>>         This could allow other users on your system to read private
>> archives.
>>         If you're on a shared multiuser system, you should consult the
>>         installation manual on how to fix this.
> This is the warning I meant to ignore.
>> /private/var/mailman/data/virtual-mailman.db owned by root (must be owned by
>> _mailman (fixing)
>> /private/var/mailman/data/virtual-mailman.db permissions must be 066x (got
>> 0100640) (fixing)
>> Problems found: 2
>> Re-run as _mailman (or root) with -f flag to fix
> You already ran it via sudo with -f so the problems with
> virtual-mailman.db should be fixed now.

More information about the Mailman-Users mailing list