[Mailman-Users] solaris10 sparc, check_perms messages

upen upendra.gandhi at gmail.com
Sun Dec 12 04:50:35 CET 2010


On Sat, Dec 11, 2010 at 9:33 PM, Mark Sapiro <mark at msapiro.net> wrote:
> upen wrote:
>>This is my first attempt to install Mailman-2.1.14 on solaris10/sparc.
>>HAving installed pythin-2.6.2 and gcc4 I then successfull did y
>>configure, gmake, gmake install. However, when I run bin/check_perms I
>>receive below messages.
>>-bash-3.00# ./bin/check_perms
>>Traceback (most recent call last):
>>  File "./bin/check_perms", line 395, in <module>
>>    checkmail()
>>  File "./bin/check_perms", line 293, in checkmail
>>    mode = statmode(wrapper)
>>  File "./bin/check_perms", line 82, in statmode
>>    return os.stat(path)[ST_MODE]
>>OSError: [Errno 2] No such file or directory: '/usr/local/mailman/mail/mailman'
> Presumably this is because the mail wrapper has some other name,
> perhaps
> /usr/local/mailman/mail/mailman.exe, but why? Or is there no
> /usr/local/mailman/mail/* mail wrapper at all?

Yes, surprisingly there was no mailman file or directory in
/usr/local/mailman/mail after installation. However, I later decided
not to use python package and gcc4 provided by Blastwave CSW and
infact removed all references to csw/lib and csw/bin from PATH and
LD_LIBRARY_PATH and decided to use old gcc version from /usr/local/bin
and python from /usr/sfw/bin and installed Mailman again. This way
everything is working fine. In fact check_perms also worked fine this
time. :)

>>Can someone throw some light on this issue?
> It may be a bug in check_perms. What options did you give to configure?
> What is the name of the mail wrapper file in /usr/local/mailman/mail/?
>>In addition, if there is
>>any howto or install document on internet for Mailman on solaris 10
>>then please let me know that too.
> Try
> <http://www.google.com/#q=site:mail.python.org+inurl%3Amailman+"solaris
> 10">
Thanks much. Issue resolved.

More information about the Mailman-Users mailing list