[Mailman-Users] Mailman web interface - specifydifferentIP:port?

Tanstaafl tanstaafl at libertytrek.org
Thu Dec 23 20:46:44 CET 2010

On 2010-12-23 2:08 PM, Mark Sapiro wrote:
>> I set:
>> DEFAULT_URL_PATTERN = 'https://%s:#####/mailman/'
>> Where ##### is the 5 digit port I set it to, then I ran:
>> # ./withlist -l -a -r fix_url


>> I also added the redirect for the non-ssl host to the ssl host per the
>> instructions at the above site:
>> RewriteCond   %{HTTP_HOST}  ^lists\.example\.com
>> RewriteRule ^(.*) https://lists.example.com:#####$1 [NC,R=301,L]
>> (##### is a 5 digit valid port that is not in use)
>> These two lines work fine for redirecting my other sites...

> I'm surprised this works for anything...
> The above two lines must either be in a VirtualHost block that applies
> only to port 80 requests

They are... but thanks for the tip on how to not rewrite if the port is
the right one already... can't hurt to add it so I did...

>> I didn't add an actual vhost directive for mailman in apache because I
>> never needed it before - I think that the settings in 50_mailman.conf
>> take care of that part...?

> Presumably they apply to all hosts which should be OK.

I meant I don't have a specific apache2 listener for mailman, like I do
for my other websites, I've only been (tryingto) add the rewrite rule (I
keep my rewrite rules in one .conf file, and the vhosts in individual
files per host)... maybe I need to create one that is listening on the
correct port, like I have for my other non-mailman vhosts?

>> Strangely, even though I did the above changes, if I remove the
>> redirect, I can get to the lists on the non-ssl url, and it seems to
>> work fine (shows the membership, etc)... ??? I haven't tried changing
>> any settings yet though...

> Without the rewrite, you should also be able to get there using the SSL
> URL.

Just tried, nope, it does the looping thing then gives the same error.

So, you're saying it is ok/normal for both the ssl and non-ssl pages to
work, even after I changed mm_cfg

As for logs...

With the redirect commented, I can get to the non-ssl pages just fine...

Trying to go to the ssl page, it gives the same error, and this is in
the error_log:

[Thu Dec 23 14:33:04 2010] [error] [client]
mod_mime_magic: can't read `/usr/lib64/mailman/cgi-bin/admin'
[Thu Dec 23 14:33:04 2010] [error] [client] client denied
by server configuration: /usr/htdocs

Then, after commenting out the redirect and restarting apache, when I
try to go to the normal page (which should redirect to the ssl page), I
get the same error, nothing in the ssl logs, and only this in the
access_log: - - [23/Dec/2010:14:37:19 -0500] "GET
/mailman/admin/listname/ HTTP/1.1" 301 349

and these two lines in the error_log:

[Thu Dec 23 14:37:06 2010] [notice] caught SIGTERM, shutting down
[Thu Dec 23 14:37:09 2010] [notice] Apache/2.2.16 (Unix) mod_ssl/2.2.16
OpenSSL/1.0.0c configured -- resuming normal operations


Is there some kind of .conf parser for apache that will show the current
configs it is using, similar to 'postconf -n' for postfix?

More information about the Mailman-Users mailing list