[Mailman-Users] Private archive nightmare with vhosts

Mark Sapiro mark at msapiro.net
Fri Jan 29 21:51:17 CET 2010

UGSD wrote:
>I got around the DNS issue with /etc/hosts, may not work in your case, i guess

Yeah, I can do that too. I've actually created another domain that way,
but I havent gotten back to debugging yet.

>After not being able to create a list, I had another issue (not seen in 2.1.7), where the alias file was created in the form of 
>lists.domain1.net=list-name-unsubscribe: "|/path/to/mailman unsubscribe lists.domain1.net=list-name"
>which mailman did not understand and complained that "lists.domain1.net=list-name" not found.
>The problem was in Mailman/MTA/Utils.py and _makealiases_mailprog() function, so i just modified it to accept another variable and use it

I'm not sure where the '=' comes from, and I don't know if this is the
issue, but Mailman/MTA/Utils.py is one of two modules that had a real
conflict when I merged the patches with 2.1.13. The attached
MTA_Utils.py.patch.txt patch is (I think) the proper fix. The secton
at "@@ -48,13 +54,12 @@" is where the problem was.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: MTA_Utils.py.patch.txt
URL: <http://mail.python.org/pipermail/mailman-users/attachments/20100129/cba06d59/attachment-0001.txt>

More information about the Mailman-Users mailing list