[Mailman-Users] Mailman on non-standard port : Public list not displayed on listinfo page

Raven Kong ravenkong at gmail.com
Tue Jun 22 11:45:28 CEST 2010

Hello Guys,

I have trouble getting the public list shown on the general listinfo page.
My mailman is install on a host with port number 8888 (80 is used by another
service), so the url address is something like
http://a.b.c:8888/mailman/listinfo. And those list created public is not
displayed in this overview page.
I've searched the wiki page and found these articles:
http://wiki.list.org/pages/viewpage.action?pageId=4030613 and
And as described in the articles I modified my mm_cfg.py  like this:

MTA = 'Postfix'
DEFAULT_URL = 'http://a.b.c'
DEFAULT_URL_PATTERN = 'http://%s:8888/mailman/'

Restart my apache, mailman, postfix and then use bin/fix_url to fix the
exist list,  it doesn't show up in the overview page. Those new list created
after the modification don't show in the overview page too.
As my understanding , in the article mentioned above, only when the *
host_name* and *web_page_url * are identical the list can be shown in the
mailman/listinfo page. The *host_name* can be reset in the list's General
Options, here in my case *host_name*=a.b.c . But my *web_page_url* -
according to the discription in the wiki faq - is *h**ttp://a.b.c:8888/mailman
or http://a.b.c:8888  (I'm not sure)*. And I can't change *host_name* to
a.b.c because if I change it to other value my mailman can't receive mails
(I've already tried *host_name*=*a.b.c:8888/mailman* or *a.b.c:8888* and it
doesn't fix the problem only to make mailman not receiving mail posts)

Is there something wrong with the mm_cfg.py file ? Or did I missed
Any information on issue like this will be greatly appreciated.

Thank you!
Best regards,

Raven Kong
--Life is not as we know it.

More information about the Mailman-Users mailing list