[Mailman-Users] Postings under one Mailman instance not seen by theother?

Dwight A. Ernest dwighternest at gmail.com
Wed Jun 23 05:04:06 CEST 2010

On Tue, Jun 22, 2010 at 22:53, Mark Sapiro <mark at msapiro.net> wrote:

> Dwight A. Ernest wrote:
> >
> >I neglected, however, to change the home directory for the mailman user to
> >the new executable path. Another sysadmin, though aware of my work,
> >innocently executed ~mailman/bin/genaliases, which came from the old RPM
> >instance.
> >
> >This caused the aliases file to grab the old path to the '.../mail/mailman
> >post' programs. List postings succeeded, according to the MTA logging, but
> >no postings actually went out. It took almost 24 hours for the problem to
> be
> >noticed, but only a few minutes to put it right.
> >
> >In the meantime, over 200 posted messages were lost. I can't find any
> trace
> >of them in the qfiles directory. If possible, I'd love to find them and
> >process them under the patched MM instance. I don't understand what
> happened
> >to them. It seems to me that if the data repository was shared between the
> >two executables instances, there should be a good chance that they were
> >processed. I can find no trace in either the RPM-related log files, nor
> the
> >patched-source-related log files.
> Since it's a RedHat rpm, have you looked in /var/spool/mailman/in ? See
> <http://wiki.list.org/x/KYCB>.
> Presumably the only qrunners that were running were the ones for the
> "working" installation so the posts have to be in the "in/" queue of
> the  RPM instance.
> --
> Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
> San Francisco Bay Area, California    better use your sense - B. Dylan
Mark, this is exactly what I needed. Thanks for the pointers. All of the
missing list traffic is being delivered as I speak.

-Dwight Ernest
dwighternest at gmail.com

More information about the Mailman-Users mailing list