[Mailman-Users] Mailman 2.1.14 Multiple Owner(s) Patch - Problem

Mark Sapiro mark at msapiro.net
Tue Sep 28 23:45:00 CEST 2010

Barry Finkel wrote:

>I am testing Mailman 2.1.14 via a Debian/Ubuntu package I built
>from the SourceForge source.  I included the "multiple list owner"
>patch from Mark Sapiro (Fri, 02 Oct 2009 13:11:06 -0700).
>I created a new list, and I specified two addresses in response to the
>     Enter the email(s) of the person running the list:
>     user1 at example.com,user2 at example2.com
>The list-creation mail was sent to both addresses, but the
>admin web page shows only the first address as the owner.

That's really strange.

>I tried creating two other test lists with two owners to see if the
>e-mail address domain had any effect:
>     list 2: user2 at example2.com,user at example.com
>     list 3: user at example.com,user2 at example.com
>The single owner in each case:
>     list 2: the second address
>     list 3: the first address

I applied the patch as downloaded from
to the 2.1.14 base. It applied cleanly except for a 1-line offset in
the 3rd and 4th hunks because the patch is against the 2.1.12 base.

I created two lists with two owners each as above and everything works
as expected. I don't see a problem.

What do you get from, e.g.

 bin/dumpdb lists/list2/config.pck | grep \'owner

In my case, I see

 bin/dumpdb lists/t2/config.pck | grep \'owner
    'owner': ['user at example.com', 'user2 at example.com'],

which is expected.

Note that with the patch, the first address is validated during the
list create process, but the second is not. Thus if there are leading
or trailing spaces or special characters in the second address, that
could cause problems.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list