[Mailman-Users] exim says 'unrouteable' on new list

Rich Lott rl6 at shinyblue.net
Sun Aug 7 00:57:22 CEST 2011


I have exim4 and mailman running successfully on my server. I have a 
working list that runs at somelistname at artfulrobot.com and a working web 
admin iface. All good.

But now I want to set up a new list under a subdomain for another 
client. This list name does not clash with my other list, and it is does 
not clash with a username on the server.

I set it up with this command

$ newlist -e maybe.artfulrobot.com -u artfulrobot.com community

I used the web iface to mass subscribe my own email address, and I got a 
"welcome" message. But when I try to send to the list, it bounces back.

Nb. I can email someotheruser at maybe.artfulrobot.com and receive it at 
someotheruser's normal user account.

I looked at the output from this command:
$ exim4 -d -bt community at maybe.artfulrobot.com

to see why it was failing. Output below.

Basically, it seems that mm has not registered 
community at maybe.artfulrobot.com in data/virtual-mailman.

I've read lots of postings, docs etc. but gotten nowhere. I've tried 
fiddling with /etc/mailman/mm_cfg.py, adding things like:

MTA=None (and MTA='None')

add_virtualhost('maybe.artfulrobot.com','maybe.artfulrobot.com' )

POSTFIX_STYLE_VIRTUAL_DOMAINS = [ 'artfulrobot.com', 

Each change I've restarted MM. Tried and got the unrouteable error again.

Can anyone help?! thanks...


--------> mailman_router router <--------
local_part=community domain=maybe.artfulrobot.com
checking domains
cached yes match for +local_domains
cached lookup data = NULL
maybe.artfulrobot.com in "+local_domains"? yes (matched "+local_domains" 
- cached)
checking require_files
file check: /var/lib/mailman/lists/$local_part/config.pck
expanded file: /var/lib/mailman/lists/community/config.pck
stat() yielded 0
checking "condition"
search_open: lsearch "/var/lib/mailman/data/virtual-mailman"
search_find: file="/var/lib/mailman/data/virtual-mailman"
   key="community at maybe.artfulrobot.com" partial=-1 affix=NULL starflags=0
LRU list:
internal_search_find: file="/var/lib/mailman/data/virtual-mailman"
   type=lsearch key="community at maybe.artfulrobot.com"
file lookup required for community at maybe.artfulrobot.com
   in /var/lib/mailman/data/virtual-mailman
lookup failed
mailman_router router skipped: condition failure
no more routers
search_tidyup called
 >>>>>>>>>>>>>>>> Exim pid=2959 terminating with rc=2 >>>>>>>>>>>>>>>>

More information about the Mailman-Users mailing list