[Mailman-Users] exim says 'unrouteable' on new list

Adam McGreggor adam-mailman at amyl.org.uk
Sun Aug 7 15:22:01 CEST 2011

On Sat, Aug 06, 2011 at 11:57:22PM +0100, Rich Lott wrote:
> Hi
> I have exim4 and mailman running successfully on my server. I have a  
> working list that runs at somelistname at artfulrobot.com and a working web  
> admin iface. All good.
> I looked at the output from this command:
> $ exim4 -d -bt community at maybe.artfulrobot.com
> to see why it was failing. Output below.
> Basically, it seems that mm has not registered  
> community at maybe.artfulrobot.com in data/virtual-mailman.

Your debug message states:

> file lookup required for community at maybe.artfulrobot.com
>   in /var/lib/mailman/data/virtual-mailman
> lookup failed

Is that correct? (i.e., does /var/lib/mailman/data/virtual-mailman...)

> I've read lots of postings, docs etc. but gotten nowhere. I've tried  
> fiddling with /etc/mailman/mm_cfg.py, adding things like:

For Exim and Mailman, I'd use the canonical document:

and that alone.

> MTA=None (and MTA='None')
> add_virtualhost('maybe.artfulrobot.com','maybe.artfulrobot.com' )
> POSTFIX_STYLE_VIRTUAL_DOMAINS = [ 'artfulrobot.com',  
> 'maybe.artfulrobot.com']

I'd not bother with that sort of thing. Just use the tried-and-tested 


> Each change I've restarted MM. Tried and got the unrouteable error again.

If you're fiddling with Exim that probably needs HUPing.

"Well, you didn't design your beard too well, did you? You really
 must try better with your beard." 
    -- DoE to a fashion designer

More information about the Mailman-Users mailing list