[Mailman-Users] exim says 'unrouteable' on new list [SOLVED]

Rich rl6 at shinyblue.net
Mon Aug 8 00:12:27 CEST 2011

Thanks Adam and Mark for your responses. I'm always amazed at the 
generosity of the open source community and I do appreciate it.

After about 4 hours fiddling I'd managed to find a fix. I think the main 
thing I was missing was that you have to run genaliases in order to 
update the lookup file.

I had read http://www.exim.org/howto/mailman21.html but not found it 
particularly enlightening, esp. the exim section. I had read a lot more, 
too. Just search this list for "virutal domain" and you'll see how many 
others have problems too, and I read through lots of those!

In the end I found /usr/share/doc/mailman/README.Exim4.Debian.gz which 
was most helpful.

For the benefit of anyone reading this, I have learnt:

1. in mm_config, it says postfix but it means exim too. Unfortunate 
lexical obfuscation ;-)

2. virtual domains look like quite a hassle with postfix, but with exim 
they're easy as long as your lists all have unique names, regardless of 
their domain (or you have to run 2 installs of mm)

3. running genaliases is needed to update existing lists.

4. beyond the instructions in README.Exim4.Debian I added a line
     for each virtualhost. I'm not sure this is needed once it's listed 
     but I'm not going to try to break it now I've finally got it working!

5. Exim +debconf rocks: debconf effortlessly ensured I avoided the 
pitfalls that seem so common from reports elsewhere on MTA config, and 
exim -d -bt some at email.address.com bends over backwards to tell you what 
it's doing.

Happy at last.

Good luck to everyone else!


On 06/08/11 23:57, Rich Lott wrote:
> Hi
> I have exim4 and mailman running successfully on my server. I have a 
> working list that runs at somelistname at artfulrobot.com and a working 
> web admin iface. All good.
> But now I want to set up a new list under a subdomain for another 
> client. This list name does not clash with my other list, and it is 
> does not clash with a username on the server.
> I set it up with this command
> $ newlist -e maybe.artfulrobot.com -u artfulrobot.com community
> I used the web iface to mass subscribe my own email address, and I got 
> a "welcome" message. But when I try to send to the list, it bounces back.
> Nb. I can email someotheruser at maybe.artfulrobot.com and receive it at 
> someotheruser's normal user account.
> I looked at the output from this command:
> $ exim4 -d -bt community at maybe.artfulrobot.com
> to see why it was failing. Output below.
> Basically, it seems that mm has not registered 
> community at maybe.artfulrobot.com in data/virtual-mailman.
> I've read lots of postings, docs etc. but gotten nowhere. I've tried 
> fiddling with /etc/mailman/mm_cfg.py, adding things like:
> MTA=None (and MTA='None')
> add_virtualhost('maybe.artfulrobot.com','maybe.artfulrobot.com' )
> POSTFIX_STYLE_VIRTUAL_DOMAINS = [ 'artfulrobot.com', 
> 'maybe.artfulrobot.com']
> Each change I've restarted MM. Tried and got the unrouteable error again.
> Can anyone help?! thanks...
> Rich
> --------> mailman_router router <--------
> local_part=community domain=maybe.artfulrobot.com
> checking domains
> cached yes match for +local_domains
> cached lookup data = NULL
> maybe.artfulrobot.com in "+local_domains"? yes (matched 
> "+local_domains" - cached)
> checking require_files
> file check: /var/lib/mailman/lists/$local_part/config.pck
> expanded file: /var/lib/mailman/lists/community/config.pck
> stat() yielded 0
> checking "condition"
> search_open: lsearch "/var/lib/mailman/data/virtual-mailman"
> search_find: file="/var/lib/mailman/data/virtual-mailman"
>   key="community at maybe.artfulrobot.com" partial=-1 affix=NULL starflags=0
> LRU list:
>   :/var/lib/mailman/data/virtual-mailman
>   :/etc/aliases
>   End
> internal_search_find: file="/var/lib/mailman/data/virtual-mailman"
>   type=lsearch key="community at maybe.artfulrobot.com"
> file lookup required for community at maybe.artfulrobot.com
>   in /var/lib/mailman/data/virtual-mailman
> lookup failed
> mailman_router router skipped: condition failure
> no more routers
> search_tidyup called
> >>>>>>>>>>>>>>>> Exim pid=2959 terminating with rc=2 >>>>>>>>>>>>>>>>
> ------------------------------------------------------
> Mailman-Users mailing list Mailman-Users at python.org
> http://mail.python.org/mailman/listinfo/mailman-users
> Mailman FAQ: http://wiki.list.org/x/AgA3
> Security Policy: http://wiki.list.org/x/QIA9
> Searchable Archives: 
> http://www.mail-archive.com/mailman-users%40python.org/
> Unsubscribe: 
> http://mail.python.org/mailman/options/mailman-users/rl6%40shinyblue.net

More information about the Mailman-Users mailing list