[Mailman-Users] Cannot exec /etc/mail/smrsh: Permission denied

Mark Sapiro mark at msapiro.net
Wed Feb 2 00:51:42 CET 2011

John Espiro wrote:

>When I send a message to the mailing list I get:
> sm-mta[16327]: p0SJuInx016321: SYSERR(root): Cannot exec
>/etc/mail/smrsh: Permission denied
>Jan 28 19:56:22 sm-mta[16326]: p0SJuInx016321:
>to="|/usr/lib/mailman/mail/mailman post LISTNAME", ctladdr=<ADDRESS>
>(8/0), delay=00:00:01, xdelay=00:00:00, mailer=prog, pri=31689,
>dsn=4.0.0, stat=Operating system error
>System: Ubuntu 10.10 Server 64bit
>I've read through this:
>grep smrsh /etc/mail/sendmail.cf
>#####  $Id: smrsh.m4,v 8.14 1999/11/18 05:06:23 ca Exp $  #####
>Mprog,  P=/etc/mail/smrsh, F=lsDFM
>smrsh is in: :/usr/lib/sm.bin
>In /usr/lib/sm.bin, I ran: ln -s /usr/lib/mailman/mail/mailman mailman
>In /etc/mail/smrsh, I ran: ln -s /usr/lib/mailman/mail/mailman mailman
>Still, the problem persists.  I am sure this must be a permissions
>issue, then again, maybe not.
>Other data:
>uid=51(smmsp) gid=51(smmsp) groups=51(smmsp),45(sasl)
>uid=103(smmta) gid=106(smmta) groups=106(smmta),45(sasl)
>uid=8(mail) gid=8(mail) groups=8(mail)
>ls -la /etc/mail/smrsh
>drwsr-sr-x 2 root  root  4096 2011-01-28 19:31 .

What are the permissions on /usr/lib/mailman/mail/mailman? are all
directories world searchable and the file world executable?

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list