[Mailman-Users] Mailman don't start

Mark Sapiro mark at msapiro.net
Mon Feb 7 18:32:00 CET 2011

Hotleine.Roland at web.de wrote:

>Hey Guys,
>since yesterday, I got following Problem with Mailman:
>After a tried restart, der process simply is not starting (I was able to do so, some days ago).
>In the qrunner-log are some messages:
>1. "Master qrunner detected subprocess quit" (this messages appears for several subprocesses)" (for alle subprocesses)
>2. and later: "Qrunner xy reached maximum restart limit of 10, not restarting"

Stop Mailman completely. See the FAQ at <http://wiki.list.org/x/_4A9>
for info on how to do this. When Mailman is completely stopped, remove
any residual lock files from Mailman's locks/ directory.

Then start Mailman.

Once a qrunner has reached it's restart limit, mailmanctl restart won't
start it again. You have to stop Mailman and then start it.

Also, why are qrunners dying? The log should have messages like

Master qrunner detected subprocess exit (pid: 30050, sig: xxx, sts:
xxx, class: xxxRunner, slice: 1/1)

which indicate the exit status which may be a clue. Also, if the
qrunner died from an uncaught exception, there should be a traceback
in Mailman's error log.

>Also, in the error-log is a message from a tried stop/restart:
>"No child process with PID xxxxx available
>[Erno 3] Nuch such process"

This indicates the running mailmanctl died unexpectedly. Did you have a
power outage or otherwise terminate these processes abnormally?

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list