[Mailman-Users] mailman on freeBSD 8.2: getgrgid error

Rekhesh Mohan reks at iiap.res.in
Sun Jul 31 22:27:10 CEST 2011

Hi folks, 
I've been fiddling with mailman 2.1.14 (from freebsd ports) on free BSD 
8.2. Everything seems to be fine so far except for the web based stuff. I 
get the following error when I try to access the page:


Mailman CGI error!!!

The Mailman CGI wrapper encountered a fatal error. This entry is being 
stored in your syslog:
Failure to find group name for GID 80.  Mailman
expected the CGI wrapper to be executed as group
"www", but the system's web server executed the
wrapper as GID 80 for which the name could not be
found.  Try adding GID 80 to your system as "www",
or tweak your web server to run the wrapper as group

This system has a www user and gid is 80 (group = www). In the first 
attempt, I let freebsd choose its own configure-arguments and later I 
tried it myself. Error remained the same. 

AFAIK, src/common.c is checking the GID with getgid() followed by 
getgrgid(). Now, my machine uses blowfish instead of md5 for passwd. 
getgid() is returning 80 - which is fine since i have gid(www) = 80 on my 
system. However, getgrgid(gid) returns null :-|  I gave up my fight at 
that point and decided to ask for help :)

I tried to figure out the behaviour of these functions with a small test 
code: getgrgid() returns gr_passwd = * for blowfish, and gr_passwd = x 
for md5. Is that an issue with mailman or am I making mistakes somewhere 
else in the installation? My apache config is given below (I followed the 
steps in installation doc.)

Thanks in advance..!

ScriptAlias /mailman/ "/usr/local/mailman/cgi-bin/"
Alias /pipermail/ "/usr/local/mailman/archives/public/"

<Directory "/usr/local/mailman">
   Options FollowSymLinks ExecCGI
   AllowOverride None
   Order allow,deny
   Allow from all

RedirectMatch ^/mailman[/]*$ http://this.great.site/mailman/listinfo/

More information about the Mailman-Users mailing list