[Mailman-Users] bug adding user, and archiving gets "shunted"

Mark Sapiro mark at msapiro.net
Thu Mar 31 19:08:48 CEST 2011

Lucio Chiappetti wrote:
>I confirm that despite the fact this message is shown on the web page, I 
>receive the regular confirmation message, and if I click on the provided 
>URL I am regularly subscribed.

This error is due to one of several known incompatibilities between
Mailman versions older than 2.1.12 and Python 2.6 or later. See the
FAQ at <http://wiki.list.org/x/pYA9>.

If suse is packaging Mailman 2.1.11 with the Python 2.6.5 that you are
apparently using, this is a serious suse packaging problem.

If you have upgraded your Python independent of suse, perhaps you can
also install Mailman 2.1.14-1 or even the head of the Bazaar
lp:mailman/2.1 branch.

As you have observed, this particular error only results in the bug
page rather than the appropriate subscription results page, but other
errors due to this incompatibility will be more disruptive.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list