[Mailman-Users] Issues with mailman

Chris Petrik c.petrik.sosa at gmail.com
Wed Nov 16 00:29:03 CET 2011

On 11/15/2011 5:09 PM, Chris Petrik wrote:
> On 11/15/2011 5:00 PM, Chris Petrik wrote:
>> On 11/15/2011 4:37 PM, Mark Sapiro wrote:
>>> On 11/15/2011 8:48 AM, Chris Petrik wrote:
>>>> % cd lists/services-officialunix.com
>>>> %ls -l |wc -l
>>>>         8
>>>> %
>>>> %ls -l
>>>> total 24
>>>> -rw-rw----  1 www      mailman  3792 Nov 15 07:35 config.pck
>>>> -rw-rw----  1 mailman  mailman  3792 Nov 15 08:03
>>>> config.pck.tmp.hosting.officialunix.com.30747
>>>> -rw-rw----  1 mailman  mailman  3835 Nov 15 08:00
>>>> config.pck.tmp.hosting.officialunix.com.74443
>>>> -rw-rw----  1 mailman  mailman  3792 Nov 15 07:48
>>>> config.pck.tmp.hosting.officialunix.com.74445
>>>> -rw-rw----  1 mailman  mailman  3792 Nov 15 08:00
>>>> config.pck.tmp.hosting.officialunix.com.74446
>>>> -rw-rw----  1 mailman  mailman   131 Nov 15 07:37 pending.pck
>>>> -rw-rw-r--  1 mailman  mailman   599 Nov 15 07:37 request.pck
>>>> %ln config.pck.tmp.hosting.officialunix.com.74446 config.pck.last
>>>> %ls
>>>> config.pck
>>>> config.pck.last
>>> Actually, I gave you the wrong advice. The ln command should have been
>>> ln config.pck config.pck.last
>>> If that works, instead of trying this via the ln command, you could try
>>> it in a python process. Again as user mailman in mailman's home 
>>> directory do
>>> bin/withlist -i
>>> This will respond with a few lines followed by a>>>  prompt. At the
>>> prompts enter
>>> import os
>>> os.unlink('lists/services-officialunix.com/config.pck.last')
>>> (ignore any non-existant file exception)
>>> os.link('lists/services-officialunix.com/config.pck',
>>> 'lists/services-officialunix.com/config.pck.last')
>>> You can enter that all on one line, or you can enter
>>> os.link('lists/services-officialunix.com/config.pck',
>>> which will result in a ... prompt to which you enter
>>> 'lists/services-officialunix.com/config.pck.last')
>>> If that works, the question is why can you do it as mailman, but the
>>> qrunners can't? Did you start Mailman by running bin/mailmanctl 
>>> start as
>>> root? If not, stop Mailman and then start is as root.
>> Hello,
>> First that option gave me an error as the file config.pck was owned 
>> by www I changed it to root:mailman still gave me a perm error so I 
>> changed it to mailmail:mailman and it worked.
>> Did the bin/withlist -i and it did the os.unlink and os.link commands 
>> without issue.
>> After changing the perms I see that it now works without issue. Guess 
>> my webpanel is the culprit. I will see if I can try and inform the 
>> developers of this so I don't have to be changing the perms to make 
>> mailman work.
>> Thank you Mark for pointing these thing out to me :)
>> Chris
> Hello,
> Now when I try to go to the admin section of the webui for the mailing 
> I get the bug page. Which is easily fixed by changing the owner from 
> mailman to www.
> I tried adding mailman to group www but that doesn't seem to work.
> Chris
I recompiled mailman with the cgi_gid changed to mailman and the apache 
config to be changed as AssignUserID mailman mailman and now I don't get 
the bug page and all is well.  I will continue to monitor the mailman 
services too see if any more perm issues arise before I create 
production mailing lists.

I am not sure if this is the proper way to run mailman but it seems to 
work, since the web panel is always open to issues and bug reports which 
is awesome it is not that hard to explain to them the issue and have 
them fix it.  Seems rather obvious mailman creates files as user mailman 
but editing the files in a web browser creates the files as the running 
user of the web server IE: www if I am not mistaken using the itk patch 
will allow the web server to create/edit files as the user set in the 
AssignUSerID directive in apache.

Thank you for the help

More information about the Mailman-Users mailing list