[Mailman-Users] postfix+mailman - User unknowninvirtualmailboxtable

J. Bakshi joydeep at infoservices.in
Sat Sep 3 20:29:21 CEST 2011

On Sat, 3 Sep 2011 10:04:19 -0700
Mark Sapiro <mark at msapiro.net> wrote:

> <joydeep at infoservices.in> wrote:
> >
> >I have set  SMTPHOST = 'localhost' at
> > /usr/lib/mailman/Mailman/mm_cfg.py
> >
> >and this has solved the issue.
> I'm glad your group mismatch problem is solved, but I can assure you
> that setting SMTPHOST = 'localhost' in mm_cfg.py is not what solved
> it. First of all, this is no different from the Defaults.py setting
> and thus didn't change anything. More importantly, SMTPHOST is used by
> Mailman only to determine to what host to connect for SMTP to deliver
> outgoing mail. It has nothing at all to do with mail delivery TO
> Mailman.
> When I referred to the 'local' transport, I was refering to the Postfix
> module that was actually piping mail to Mailman. I.e. in a Postfix log
> entry for delivery to Mailman what you see as see "relay=...".
> So I don't know what actually solved your problem. Perhaps you removed
> list aliases from /etc/aliases and neglected to run "newaliases" or
> "postalias /etc/aliases" until sometime later or you did something
> else that solved the problem, but it wasn't just setting SMTPHOST =
> 'localhost' in mm_cfg.py.

Well.. then I am also confused to think what actually solve the issue...
When I first face the gid problem, I have removed the aliases from
/etc/aliases and add hash:/var/lib/mailman/data/aliases at the 
alias section, and not run newaliases any more as suse automatically
add/remove aliases from /var/lib/mailman/data/aliases; I have come to
know this from suse doc and also confirm by checking the file.
Even after all those steps, I faced the gid issue. And now with
SMTPHOST = 'localhost', I don't have it any more. So I am also confused
what solved the issue. Though I am relaxed... the list is working :-)

More information about the Mailman-Users mailing list