[Mailman-Users] postfix+mailman - User unknowninvirtualmailboxtable

Mark Sapiro mark at msapiro.net
Mon Sep 5 07:30:32 CEST 2011

J. Bakshi wrote:
>Well.. then I am also confused to think what actually solve the issue...
>When I first face the gid problem, I have removed the aliases from
>/etc/aliases and add hash:/var/lib/mailman/data/aliases at the 
>alias section, and not run newaliases any more as suse automatically
>add/remove aliases from /var/lib/mailman/data/aliases; I have come to
>know this from suse doc and also confirm by checking the file.

It is correct that with MTA = 'Postfix' Mailman automatically runs

/usr/sbin/postalias /path/to/data/aliases

whenever aliases are updated,and likewise

/usr/sbin/postmap /path/to/data/virtual-mailman


However it doesn't update /etc/aliases.db. Thus, if you just removed
Mailman's aliases from /etc/aliases and did not run newaliases or
"postalias /etc/aliases", /etc/aliases.db still had the Mailman
aliases and that was the problem. Then at some point, you did update
/etc/aliases.db and that is what fixed the problem.

>Even after all those steps, I faced the gid issue. And now with
>SMTPHOST = 'localhost', I don't have it any more. So I am also confused
>what solved the issue. Though I am relaxed... the list is working :-)

As I said. I'm glad it's working, but you could remove the SMTPHOST =
'localhost' from mm_cfg.py, and it will continue to work.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list