[Mailman-Users] Mailman lists are set up but posts to the lists arenot arriving

jhock jhock at iinet.net.au
Fri Sep 16 09:20:31 CEST 2011

On Thu, 2011-09-15 at 22:07 -0700, Mark Sapiro wrote:
> jhock wrote:
> >
> >I have set up Mailman and can create lists etc. I can subscribe to the
> >lists but I can't post to the lists. The posts don't get delivered.
> >
> >I have looked at the FAQs and searched the WIKI but I can't find an
> >answer to my problem. I have been working on this for days. Cann someone
> >please help me?
> >
> >I using:
> >
> >Mailman version: 2.1.14
> >Python 2.5.2
> >Debian GNU/Linux 5.0.5
> >Exim version 4.69 #1 built 30-Sep-2008 18:54:33
> >
> >my configuration is:
> >
> >MAILMAN_USER = 'mailman'
> >MAILMAN_GROUP = 'mailman'
> >--with-mail-gid=Debian-exim --with-cgi-gid=www-data

> The above is wrong. Assuming that
> MAILMAN_USER = 'mailman'
> MAILMAN_GROUP = 'mailman'
> are from your exim config and 
> --with-mail-gid=Debian-exim --with-cgi-gid=www-data
> were options to configure, it should have been
> --with-mail-gid=mailman
> I.e. whateve you configure with --with-mail-gid must match
Hi Mark,

Thanks for your prompt reply.

The exim4 daemon runs with group id = Debian-exim. That is why I
configured Mailman --with-mail-gid=Debian-exim. I assumed that the
mail-gid was the group id of the mail daemon.

However, I have reconfigured Mailman --with-mail-gid=mailman as you

> >I have tried to apply to the content of section 6.2 in the
> >mailman-2.1.14-1/doc/mailman-install.txt
> >
> >/etc/exim4/conf.d/main/04_local_mailman_macros
> >/etc/exim4/conf.d/router/970_local_mailman
> >/etc/exim4/conf.d/./transport/40_local_mailman
> Did you read the note at the beginning of section 6.2 which says in
> part "The updated document is here:
> http://www.exim.org/howto/mailman21.html and is recommended over the
> information in the subsections below if you are using Exim 4."

That document is even less helpful. It doesn't mention what files to add
the lines:



domainlist mm_domains=list.example.com

There is nothing in the mailman/Mailman/Defaults.py that has MM_HOME
etc. however there is reference to MAILMAN_HOME etc. Hence I used what
was in the documentation with the mailman/doc/mailman-install.txt files.

I have no idea in which file(s) to add the:

accept  domains = +local_domains
        message = unknown user
        verify  = recipient

accept hosts =


The list verification output seemed to be correct so I guess the content
of the mailman/docs/mailman-install.txt file worked expect that the
messages were not getting through.

I think that the exim4 needs to be changes to allow to and from external
emails but I have no idea how to do this.

> >The content of my:
> >syslog
> >apache error logs and
> >mailman error logs
> >
> >tell me nothing that I can understand.
> Well, you are coming here for help because we might be able to
> understand what's in those logs, but not if we don't see them. The
> apache logs aren't relevant to "can't post" issues, but the other's
> are, so what's in them.

The entry in the exim4/rejectlog is:

2011-09-16 14:53:08 H=localhost (asdd.osdm.gov.au) []
F=<mailman-bounces+info=mymaps.gov.au at mymaps.gov.au> temporarily
rejected RCPT <info at mymaps.gov.au>: expected "sender[=address]",
"recipient", "helo", "header_syntax", "header_sender" or
"reverse_host_lookup" at start of ACL condition "verify recipients"

I tried Googling part of that string but I didn't find anything to
overcome the problem.  

The entry in the mailman/log/post file is:

Sep 16 14:53:08 2011 (25420) post to mymaps-l from
mailman-bounces at mymaps.gov.au, size=551,
message-id=<mailman.1.1316133151.10188.mymaps-l at mymaps.gov.au>, 1

The entry in the smtp file is:

Sep 16 14:53:08 2011 (25420)
<mailman.1.1316133151.10188.mymaps-l at mymaps.gov.au> smtp to mymaps-l for
1 recips, completed in 0.069 seconds

The entries in the smtp-failure file are:

Sep 16 14:53:08 2011 (25420) All recipients refused:
{'info at mymaps.gov.au': (451, 'Temporary local problem - please try
later')}, msgid: <mailman.1.1316133151.10188.mymaps-l at mymaps.gov.au>
Sep 16 14:53:08 2011 (25420) delivery to info at mymaps.gov.au failed with
code 451: Temporary local problem - please try later

Does this help you tell me what I need to do?



More information about the Mailman-Users mailing list