[Mailman-Users] List not sending out a welcome message

Mark Sapiro mark at msapiro.net
Mon Feb 6 23:57:27 CET 2012

Brian Carpenter wrote:
>I have one list that is not sending out it's welcome message to new 
>subscribers and password reminder to its list members. All of the other 
>lists on the server are. I assume it's a db issue but could be wrong. 
>Any suggestion on where to look at what the problem could be?

Are the list's General Options settings send_reminders and
send_welcome_message set to Yes?

If so, you could visit the various member options pages via the email
address links on the Membership Management... -> Membership List pages
and verify that their "Get password reminder email for this list?"
settings are not all No. If they are all No, do

bin/config_list -o - LISTNAME | grep new_member_options

convert the decimal integer you see to binary and see if it contains
the 00100000 (2^5 = 32) bit which is the option to supress password
reminder. If it does, also check mm_cfg.py for a
DEFAULT_NEW_MEMBER_OPTIONS setting containing this bit.

If all of the above indicates reminders and welcome messages should be
sent, try running 'cron/mailpasswds -l LISTNAME' and subscribing a new
member and check Mailman's 'smtp' log and the MTA logs to see if the
messages are being sent and what's happening to them.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list