[Mailman-Users] digest-mode not functioning properly

Mark Sapiro mark at msapiro.net
Sat Feb 25 19:53:37 CET 2012

Lluis Montoliu wrote:
>The fact that two of my lists are experiencing these problems and not  
>the rest suggest me that some email addresses that could be shared  
>among the two could be the culprit. I'm investigating this.

This doesn't seem likely.

>Currently, problems can't be related to digest messages themselves,  
>because when I trigger their distribution, manually, from admin panel,  
>they are indeed distributed. Simply they are not distributed daily, or  
>when they reach 256 kb, as current settings indicate and sort of keep  
>accummulating messages in an endless manner.

It is difficult to imagine what could be causing this. Digests are
working as expected for some lists so cron/senddigests is running.
Digests can be sent manually from the web admin GUI for the affected
lists only they are not sent periodically (via cron/senddigests) or
when triggered on size. This is very mysterious.

You could try to go to the web admin Digest options page for the
affected lists and set digestable to No and Submit Your Changes. This
will produce a warning about digest members not receiving mail which
you can ignore. Then set digestable back to Yes and Submit Your
Changes again. This entire process should have no net effect, but it
may clear some strange condition if there is one.

It is unfortunate that the hosting service isn't more interested. They
say Mailman is outdated, yet there are releases from 2.1.12 through
2.1.14 that are significantly newer than the 2.1.11 release they are
running. In any case, if you could get them to look at Mailman's error
log to see if there are any errors related to these digests, maybe we
could figure out what's going on.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list