[Mailman-Users] digests not getting sent

Anil Jangity anilj at me.com
Sun Jan 22 03:55:16 CET 2012

Using the Solaris python version:

{imsadmin at olida 43}% /gcs/app/mail/listsp/mailman/cron/senddigests --listname=ade
List: ade: problem processing /gcs/app/mail/listsp/mailman/lists/ade/digest.mbox:
decoding Unicode is not supported
{imsadmin at olida 44}% 

Digest mbox file:

-rw-rw----   1 imsadmin ims         2634 Jan 21 18:51 testlists/digest.mbox

{imsadmin at olida 49}% /gcs/app/mail/listsp/python2.7/bin/python /gcs/app/mail/listsp/mailman/cron/senddigests --listname=testlists
{imsadmin at olida 50}% 

The digest.mbox file is gone, nothing in logs/smtp.
This is very bad, there is no error and Mailman just deleted the mbox file. How can I debug this?

{imsadmin at olida 36}% /usr/bin/python
Python 2.4.6 (#1, Dec 13 2009, 23:45:11) [C] on sunos5
Type "help", "copyright", "credits" or "license" for more information.
>>> import email
>>> email.__version__

On Jan 21, 2012, at 1:30 PM, Anil Jangity wrote:

> Hi, 
> I ran into a problem with digests not getting sent and I found out the root cause to be something like this, on Solaris:
> http://mail.python.org/pipermail/mailman-users/2009-September/066979.html
> So, I compiled my own Python 2.7, and tried to send 
> /path/to/python2.7 -S /path/to/senddigests
> That reported no errors, and I found 'lists/*/*digest.mbox' getting processed, as far as I can tell. The files disappeared after running the above command.
> Where is the logging for digests? 
> How do I know it's really working? I created a test list and added a member with Digest options. Sent some emails as another member, then ran that command. I have not received any email so far.
> Thanks!

More information about the Mailman-Users mailing list