[Mailman-Users] Outgoing Runner won't start

David Whitehurst dlwhitehurst at me.com
Tue Dec 9 15:38:08 CET 2014


I made some changes to the config for Postfix relating to SMTP and virtual hosting and then my installed version 2.1.18rc3 ran all runners but then I got a message from my VM host telling me that my CPU was off the charts.  Each runner was taking approx. 50% CPU so each <mailman>/bin/mailmanctl start would take the CPU from 0.0 to about 8 in less than a minute.

I finally removed the mailman I hand built and used yum install mailman and got a fresh installation that went to /usr/lib instead of my install at /usr/local.  I was familiar with the configs and after I ran check_perms and did a few other things, it works.

With Postfix and Dovecot, I have to add e.g. dev at mydomain and dev-owner at mydomain to MySQL in a virtual_users table because I’m using SSL for server accounts.  The SMTP and virtual_host configs allowed me to get member mail too now at dlwhitehurst at me.com <mailto:dlwhitehurst at me.com>

It seems that everything is working now.  I found that the yum install mailman for my CentOS is actually an earlier version 2.1.15



David Whitehurst
dlwhitehurst at me.com


David L. Whitehurst

> On Dec 9, 2014, at 9:27 AM, Mark Sapiro <mark at msapiro.net> wrote:
> On December 8, 2014 11:52:36 AM PST, David Whitehurst <dlwhitehurst at me.com> wrote:
>> I’m having trouble getting outgoing runner to start.  Basically, all
>> the emails that I created for the list on Postfix and the actual list
>> works fine, but the members aren’t getting email. The end of qrunner in
>> <mailman>/logs/ shows that all runners started except outgoing runner.
>> It tried 10 times and gave up.
> What are the actual qrunner log messages when Outgoing Runner dies?
> What's in Mailman's error log?
> -- 
> Mark Sapiro <mark at msapiro.net>
> Sent from my Android phone with K-9 Mail. [Unpaid endorsement]

More information about the Mailman-Users mailing list