[Mailman-Users] [Mailman-Developers] Kernel update breaks Mailman!!

Lindsay Haisley fmouse at fmp.com
Thu Feb 20 23:45:28 CET 2014

On Thu, 2014-02-20 at 14:39 -0500, Barry Warsaw wrote:
> >I'm running Mailman 2.1.15 on a Ubuntu server, feeding into Courier MTA,
> >running Python 2.7.3.  I track security updates and install them
> >promptly when they're issued by Ubuntu.  Yesterday I updated the Linux
> >kernel from 3.2.0-58-generic (x86_64) to 3.2.0-59-generic and Mailman
> >quit working.  List posts made it through to the archives, and were
> >apparently queued within Mailman, but wouldn't go out.  The mail server
> >was working OK for non-list email. Today I backed out the kernel update
> >and posts to lists sent yesterday and today are going out without
> >problems.
> I'm really quite surprised about this.  From the kernel version numbers, I'm
> guessing you're running Ubuntu 12.04 LTS?  I have my personal Mailman server
> running on that OS, and just performed a kernel update.  I'm about to reboot
> it into the new kernel, so I'll send a test message out and see if it works.
> Very odd that a kernel update alone would cause the problem.  Can you send
> mail normally (i.e. outside of Mailman) and connect to your port 25?  I guess
> the one difference between our setups is that I use Postfix.

I'm very surprised too!!  I've never seen this kind of thing before.
There are several pieces in the mix, including spamd running on mail
inbound to Mailman.  I'm using James Henstridge's relatively old (10
years) SpamAssassin.py module inserted into the processing of inbound
list mail via GLOBAL_PIPELINE.insert and OWNER_PIPELINE.insert.  These
have worked well up to this point.  The fact that the inbound list mails
showed up in the Mailman list archives tells me that this is working OK.

As it was, no sooner had the box come up with the previous kernel than
the MTA's queue took off like a frightened duck!  There were over 4000
messages in it (all legit, via a customer with a large list who was
desperate to get a list email out and had tried sending it several
times) within a couple of minutes.

My instinct says that there's some subtle change to kernel IPC that's
causing this.

Lindsay Haisley       | "Everything works if you let it"
FMP Computer Services |
512-259-1190          |          --- The Roadie
http://www.fmp.com    |

More information about the Mailman-Users mailing list