[Mailman-Users] Problem with messages held in Moderator Queue

Andy Jeffries andy at andyjeffries.co.uk
Fri Feb 21 17:07:23 CET 2014

I run a mailman (2.1.14-3ubuntu0.1) mailing list for a client.  There are
currently 14 emails stuck in the moderator queue.  We've tried over and
over again to choose to Discard them and click on Submit.

Every time, the HTTP request POSTs to
/cgi-bin/mailman/admindb/mailing-list-name-here, which 301 redirects to the
same URL and the GET request loads exactly the same as before (i.e. it
didn't remove any of the stuck emails).

I've had a look at the filesystem and the
/var/lib/mailman/lists/mailing-list-name-here/request.pck file's timestamp
gets updated.

That file (and the ones named
/var/lib/mailman/data/heldmsg-mailing-list-name-here-10.pck) are owned by
the "list" group which has "www-data" as a member (Nginx operates as

Can anyone suggest what I should try next to get the web interface working?

I know they can be deleted via a command line script, but I'm assuming if I
do that, I'm going to be always doing this and I want the client to be able
to do it themselves via the web interface.

Many thanks,


More information about the Mailman-Users mailing list