[Mailman-Users] Why do my posts to own mailman list disappear.

Paul Arenson/tokyoprogressive paul at tokyoprogressive.org
Sun Aug 23 08:12:43 CEST 2015

Thank you Stephen…..

> On Aug 22, 2015, at 8:22 PM, Stephen J. Turnbull <stephen at xemacs.org> wrote:
> Paul Arenson/tokyoprogressive writes:
>> I looked in Cpanel and could see no directory starting with /usr/.


> cPanel won't give you access to that, I'm pretty sure.  You need to
> have shell access to the host or virtual machine.  If you don't know
> if you have shell access, you probably don't.  Large hosting services
> tend to be quite stingy about handing out shell access.

I guess maybe I don’t.  Just normal FTP. 

turnlefthosting.org <http://turnlefthosting.org/> was my idea to run a simple hosting service. With reseller hosting, in my case I don’t sell anything, but donate webspace
to NPOs. Because it is a resller account with what I think it is called WHM, I create space for their domains. They get their own CPanel.

So turnlefthosting.org <http://turnlefthosting.org/> also hosts nangoku-jiyu-jin.net <http://nangoku-jiyu-jin.net/>, gale-sig.org <http://gale-sig.org/>, welljapan.org <http://welljapan.org/>, tokyoprogressive.org.uk <http://tokyoprogressive.org.uk/>.

In fact, I realize now I don’t need all this complexity. I could do the same thing with a regular account and add-on domains.

But as I have it, I can create lists for the different domains using their version of CPanel and Softaculous.

>> I have a reseller account
> What does that mean?  Aha, I see.  *You* are turnlefthosting.org, but
> the PTR says your IP is assigned to 100tb.com, so you're the reseller
> for somebody who actually runs the hardware.

Actually I am not sure what PTR is…..but my reseller hosting is just that, I pay for space from EZPZ and
then can do as described above.
> A little bit of browsing the related DNS shows quite a bit of a mess.
> None of the published domains properly roundtrip A -> PTR -> A, they
> just lead into a maze of little twisty passages all alike.  That
> doesn't necessarily cause a problem by itself, but it often makes
> problems harder to diagnose.

I see. Not sure exactly what that means….but thanks...
>> and nangoku-jiyu-jin.net <http://nangoku-jiyu-jin.net/> is a subset
>> of turnlefthostimg.org <http://turnlefthostimg.org/>,
> I think you're going to have to ask your upstream for help on this.

> That said there are a few long shots you could try to diagnose it
> yourself.  One is a manual transaction with the mailserver and see if
> it's being rejected at the SMTP level.

What would I need to do?

> Another thing I noticed is that you typoed "turnlefthosting.org" as
> "turnlefthostimg.org" in the above.  Is it possible that you typoed a
> host or list name somewhere in a recent configuration ichange?

Nothing changed at all in my list.  It was working with no problems for 
2 years.  Recently I have been getting a lot of spam, so when a sufficient number had built
up I went in and got rid of it using BAN so-and-so, DISCARD, so and so…

I am suspicious that I did something at this level, but can’t see anything that would cause 
that problem….
> Do you have a personal mailbox on nangoku-jiyu-jin.net?  If so, does
> that work?

Yes, both paul at nangoku-jiyu-jin.net <mailto:paul at nangoku-jiyu-jin.net> and paul at turnlefthosting.org <mailto:paul at turnlefthosting.org> work when sent mail from another address.

BUT it is going on 5 minutes that I sent mail FROM each of those addresses to themselves and they did NOT arrive.

An SMTP level error?

They show up in their respective SENT folders and I get no error message.

This sounds like NOT a MAILMAN problem…

The last time I used the nangoku-jiyu-jin account to send was actually to mailman in July for the newsletter, which went through, so 
something has happened in the last month to affect SENDING from my domains it seems.

> I suppose you are the owner of your lists.  Have you tried writing to
> <listname>-owner at nangoku-jiyu-jin.net?  It should forward to you.

Just tried, from a different domain, and am still waiting for a response.  Suggests it is not ONLY an SMPT problem?

> According to the page at
> http://www.nangoku-jiyu-jin.net/mailman/listinfo/mailman, the mailman@
> list is hosted by dionysus.thewebhostserver.com, and the owner is
> root at dionysus.thewebhostserver.com.  This is probably typical of
> cPanel (which has its own way of handling virtual hosting), but you
> should check your own listinfo and admin pages to be sure the virtual
> hosting is working correctly and everything points to

> nangoku-jiyu-jin.net.  (You may have trouble finding the proper
> Mailman interface, though, because cPanel has its own idiosyncratic
> management interface, and may even make the original inaccessible.)

This is it, right?

http://nangoku-jiyu-jin.net/mailman/listinfo/tokyoprogressive_nangoku-jiyu-jin.net <http://nangoku-jiyu-jin.net/mailman/listinfo/tokyoprogressive_nangoku-jiyu-jin.net>

webhostserver is the name EZPZ (my webhosting provider) assigns.  I am not sure about the dionysus….

> Are your lists archived?

yes, here:

http://nangoku-jiyu-jin.net/pipermail/tokyoprogressive_nangoku-jiyu-jin.net/ <http://nangoku-jiyu-jin.net/pipermail/tokyoprogressive_nangoku-jiyu-jin.net/>

>> Then I figured out my FTP login and got in using the Transmit
>> program.
> I don't think this will help.  Most FTP server software is hard to
> secure, and standard practice of hosting systems is to chroot them
> (that means that only a part of the filesystem is visible to the FTP
> server, and in fact to any programs run by the FTP server).  chroots
> are almost impossible to break unless you have shell access (which is
> one reason why hosting services are kechi about handing out shell).

You are in Japan by any chance? You know the term “kechi”.
There is an historian on Japanese history with your name, but wait, there is an academic at Tsukuba
with the same name.  (I was there for two years starting in 2009 or 10).

>> I click on usr and get Could not change directory to /usr
>> Server said can’t change directory to /usr: No such directory.
>> Error -125: remote chdir failed.
> That's bizarre.  I wonder if your host knows what it's doing.

I wonder….EZPZ is pretty big, but i guess that doesn’t necessarily mean anything….Also, this is an installation from the Softaculous package, so
I doubt they even support it.

>> There is a cpanel folder but that doesn’t seem to help.
> I'm not surprised.
> Good luck,
> Steve

Thanks for all the brainstorming.


More information about the Mailman-Users mailing list