[Mailman-Users] Impossible to remove mailing lists with ./rmlist

Luca Mazzaferro luca.mazzaferro at rzg.mpg.de
Mon Feb 16 12:14:51 CET 2015

Hi Mark,
I found the problem.
After the installation, I configured the file:


To store the data, lists and archives in external filesystem (now they 
are commented because I solved in another way)
#DATA_DIR = '/data/mailman/data'
#PUBLIC_ARCHIVE_FILE_DIR = '/data/mailman/archives/public'
#PRIVATE_ARCHIVE_FILE_DIR = '/data/mailman/archives/private'
#LIST_DATA_DIR = '/data/mailman/lists'

It seems that this configuration is completely ignored.

Anyway I solved restoring the default configuration, coping the 
/var/lib/mailman content
into /data/mailman and linking the /var/lib/mailman to /data/mailman.

In this way everything works, but the question remain:
is it normal that the mm_cfg.py is ignored?
Do I configured it in a bad way?

Thank you.

     Luca M.

On 02/13/2015 05:54 PM, Mark Sapiro wrote:
> On 02/13/2015 01:11 AM, Luca Mazzaferro wrote:
>> If I do:
>> /usr/lib/mailman/bin> ./list_lists
>> 9 matching mailing lists found:
>>         Mailman - The site list
>>        Testlist - [no description available]
>>      Testlist10 - [no description available]
>>      Testlist11 - [no description available]
>>       Testlist2 - [no description available]
>>       Testlist3 - [no description available]
>>       Testlist4 - [no description available]
>>       Testlist5 - [no description available]
>>       Testlist7 - [no description available]
>> so now I would remove Testlist10 for example:
>> /usr/lib/mailman/bin> ./rmlist Testlist10
>> Not removing archives.  Reinvoke with -a to remove them.
>> testlist10 list info not found as /var/lib/mailman/lists/testlist10
>> /usr/lib/mailman/bin> ./rmlist testlist10
>> Not removing archives.  Reinvoke with -a to remove them.
>> testlist10 list info not found as /var/lib/mailman/lists/testlist10
>> So it is not removed.
>> More over:
>> /usr/lib/mailman/bin> ls -ls /var/lib/mailman/lists/
>> total 4
>> 4 drwxrwsr-x 2 root mailman 4096 Jan 22 15:25 mailman
>> But the web interface still show that list and allow me to manage that.
> This is a bit of a mystery. My first thought is you have two Mailman
> installs and the one in /usr/lib/mailman and /var/lib/mailman is not the
> one your web server is accessing. This may be true, but it's more
> complicated than that because /usr/lib/mailman/bin/list_lists sees the
> lists but /usr/lib/mailman/bin/rmlist thinks lists are in
> /var/lib/mailman/lists/ and they aren't there.
> How did you create the lists? Via the web or with
> /usr/lib/mailman/bin/newlist or ??
> Where does your web server look for Mailman CGIs (ScriptAlias in Apache)?
> What does 'ls -l /usr/lib/mailman /var/lib/mailman' show?

More information about the Mailman-Users mailing list