[Mailman-Users] An oldie but a goodie: Operation not permitted

David Benfell benfell at parts-unknown.org
Tue Jan 27 11:39:11 CET 2015

Hi all,

I'm running on FreeBSD:
FreeBSD home.parts-unknown.org 10.1-STABLE FreeBSD 10.1-STABLE #0 r277524: Thu Jan 22 00:14:29 PST 2015     root at home.parts-unknown.org:/usr/obj/usr/src/sys/GENERIC  amd64

All of a sudden mailman isn't starting:

home# service mailman start                            
No problems found
Traceback (most recent call last):
  File "/usr/local/mailman/bin/mailmanctl", line 556, in <module>
  File "/usr/local/mailman/bin/mailmanctl", line 391, in main
    lock = acquire_lock(force)
  File "/usr/local/mailman/bin/mailmanctl", line 215, in acquire_lock
    lock = acquire_lock_1(force)
  File "/usr/local/mailman/bin/mailmanctl", line 203, in
    if not force or qrunner_state():
  File "/usr/local/mailman/bin/mailmanctl", line 187, in qrunner_state
    os.kill(pid, 0)
OSError: [Errno 1] Operation not permitted

I ran bin/check_perms ; it found no problems. I ran bin/check_db ; it
found nothing to do.

What now?

David Benfell <benfell at parts-unknown.org>
See https://parts-unknown.org/node/2 if you don't understand the
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://mail.python.org/pipermail/mailman-users/attachments/20150127/57428922/attachment.sig>

More information about the Mailman-Users mailing list