[Mailman-Users] Troubleshooting help needed

John Swartzentruber johnslists at mcswartz.org
Mon Oct 12 00:05:20 CEST 2015


I've been off this list for a few years, but suddenly today I've run 
into a problem and I'm stumped. I suspect it might be a postfix problem, 
not a mailman problem, but I'm not really sure and I'm hoping someone 
here can give me some pointers.

Until this morning I've had mailman working fine for me (for many years 
and over one year with my current server, which is running CentOS 6). 
Basically one small list that is active daily and a few other lists that 
are mostly inactive. I wanted to disable two of the inactive lists 
without removing them or their archives. To do this, I edited my 
/etc/mailman/virtual-mailman file and added "# " in front of all of the 
entries for those lists. I did the same in the /etc/mailman/aliases 
file. Prior to these edits I had googled and found some messages from 
Mark that seemed to indicate that this was an appropriate approach.

I rebuilt the /etc/mailman/virtual-mailman.db file using "postmap 
virtual-mailman" command. I think I failed to rebuild the aliases.db 
file at this point. I reloaded postfix (postfix reload). I assumed 
everything was fine and went about my day. Around noon I received an 
email from a list user indicating that the list was down. When he 
posted, he got this error:

<heap at xxxx.com>: unknown user: "heap"

Since that time, I've tried about everything to get the lists working again. I uncommented the lines. I've deleted and rebuilt the aliases.db and mailman-virtual.db files. I always reload postfix after any changes. I even rebooted the server. No luck.

As a workaround, I tried to create an alias to a list of email addresses (i.e., bypassing mailman). This alias also is reported as not existing. I'm stumped. None of my other files have changed recently (based on file dates). I don't see any errors in my /var/log/maillog or /var/log/messages logs. Or in any of the /var/log/mailman logs.

My assumption is that some configuration file has an error in it that is keeping all virtual addresses or aliases from working, but I can't see where the error is and I don't get any errors that tell me about it.

One other odd thing that I saw was the at some point after I deleted the aliases.db file, it wasn't getting rebuilt when I ran "newaliases". I ended up rebuilding it using makemap directly.

As I said, I would greatly appreciate any pointers. Is there a log file that I'm missing? Any good way to get diagnostic output or trace things?


More information about the Mailman-Users mailing list