[Mailman-Users] Troubleshooting help needed

John Swartzentruber johnslists at mcswartz.org
Mon Oct 12 02:18:53 CEST 2015

On 10/11/2015 7:31 PM, Mark Sapiro wrote:
> On 10/11/2015 03:05 PM, John Swartzentruber wrote:
>> Until this morning I've had mailman working fine for me (for many years
>> and over one year with my current server, which is running CentOS 6).
>> Basically one small list that is active daily and a few other lists that
>> are mostly inactive. I wanted to disable two of the inactive lists
>> without removing them or their archives. To do this, I edited my
>> /etc/mailman/virtual-mailman file and added "# " in front of all of the
>> entries for those lists. I did the same in the /etc/mailman/aliases
>> file. Prior to these edits I had googled and found some messages from
>> Mark that seemed to indicate that this was an appropriate approach.
> OK
>> I rebuilt the /etc/mailman/virtual-mailman.db file using "postmap
>> virtual-mailman" command. I think I failed to rebuild the aliases.db
>> file at this point. I reloaded postfix (postfix reload). I assumed
>> everything was fine and went about my day. Around noon I received an
>> email from a list user indicating that the list was down. When he
>> posted, he got this error:
> Run
> postmap /etc/mailman/virtual-mailman
> and
> postalias /etc/mailman/aliases
> assuming those are the correct paths, and run them both as the 'mailman'
> user. In any case, the resultant virtual-mailman.db and aliases.db
> should be both user and group 'mailman' or whatever the mailman
> user/group is on your system.
> Note that the command is postmap for the virtual maps and postalias for
> the aliases;
> If that doesn't fix it, post the output from 'postconf -n' and the
> postfix log messages for a failed delivery.

Thanks Mark. That seems to have made things work. I'm guessing the 
problem must have been that my aliases.db and virtual-mailman.db files 
were root:mailman, not mailman:mailman. I did a chown on them and my 
message just went through.

For future reference, where is the postfix log? Is this just the normal 
/var/log/maillog file?
Also, how do I run those commands as the mailman user? I tried "su 
mailman" and "su - mailman", but it says "This account is currently not 
available". I see that it is listed as nologin in /etc/passwd.

Thanks again for your help. I'm glad things are working again and I have 
some clue as to how I inadvertently broke things.

More information about the Mailman-Users mailing list