[Mailman-Users] Troubleshooting help needed

Mark Sapiro mark at msapiro.net
Mon Oct 12 02:40:16 CEST 2015

On 10/11/2015 05:18 PM, John Swartzentruber wrote:

> Thanks Mark. That seems to have made things work. I'm guessing the
> problem must have been that my aliases.db and virtual-mailman.db files
> were root:mailman, not mailman:mailman. I did a chown on them and my
> message just went through.

OK, good.

The important thing is the owner of the aliases.db file. See the
"DELIVERY RIGHTS" paragraph in 'man 8 local'. That file needs to be
owned by mailman and not by root.

Postfix will attempt to invoke the pipe in the alias as the owner of the
aliases.db file unless that is root in which case it will invoke it as
the configured 'default_privs' user which is usually 'nobody' and that
won't work.

> For future reference, where is the postfix log? Is this just the normal
> /var/log/maillog file?

Yes, that would be it.

> Also, how do I run those commands as the mailman user? I tried "su
> mailman" and "su - mailman", but it says "This account is currently not
> available". I see that it is listed as nologin in /etc/passwd.

Something like

sudo -u mailman postalias /etc/mailman/aliases

and similarly for postmap.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list