[Mailman-Users] UnicodeDecodeError with Mailman 2.1 and Python 2.6

David Magda dmagda at ee.ryerson.ca
Wed Sep 2 03:38:34 CEST 2015

> On Sep 1, 2015, at 21:02, Mark Sapiro <mark at msapiro.net> wrote:
> In my testing with GNU grep on Ubuntu 15.04, 'grep "\xea"' interprets \x
> as a literal x and therefore looks for the string "xea", not for the
> character whose hex value is EA.

For the record/archives: GNU grep also as the “-P” option, which allows Perl regexes (PCRE), and \xhh searches for characters with hex code hh (per pcrepattern(3)):

	http://stackoverflow.com/questions/3001177/  how-do-i-grep-for-all-non-ascii-characters-in-unix

>> Doing a "arch --wipe mylist" seems to have solved the issue, though now
>> I'm curious to know why \xea was a problem before but suddenly isn't after
>> the wipe.
> Here's what I suspect was going on.
> Your first run of bin/arch encountered some non-ascii in a header and
> threw the exception, but not before writing bad data to the pipermail
> database for that month.
> You then "fixed" the non-ascii in the input mbox, but subsequent runs of
> bin/arch still encountered the bad data in the database when they got to
> that month.
> Finally, you added the --wipe option and that removed everythin and
> rebuilt from scratch and as there was no non-ascii in the mbox headers,
> it worked.
> As to why this didn't happen before, see my next reply.

Sounds plausible.

More information about the Mailman-Users mailing list