[Mailman-Users] Error while searching the archives

Mark Sapiro mark at msapiro.net
Tue Jul 19 14:38:10 EDT 2016

On 07/19/2016 01:56 AM, Odhiambo Washington wrote:
> In mm_cfg.py, I have:
> HTDIG_HTSEARCH_PATH = '/usr/local/www/cgi-bin/htsearch'
> I tried running it:
> root at gw:/usr/home/wash # /usr/local/www/cgi-bin/htsearch
> Enter value for words: walu
> Content-type: text/html
> <html><head><title>htsearch error</title></head>
> <body bgcolor="#ffffff">
> <h1>ht://Dig error</h1>
> <p>htsearch detected an error.  Please report this to the
> webmaster of this site by sending an e-mail to:
> <a href="mailto:unconfigured at htdig.searchengine.maintainer
> <mailto:unconfigured at htdig.searchengine.maintainer>">unconfigured at htdig.searchengine.maintainer</a>
> The error message is:</p>
> <pre>
> Unable to read word database file
> '/usr/local/share/htdig/database/db.words.db'
> Did you run htdig?
> </pre>
> </body></html>

That's good as far as it goes. Making it actually work from the command
line is more complicated than that. It expects environment variables and
POST data from the search form.

Has this ever worked? If so, what did you do just prior to its stopping
working? Have you made any changes and not restarted Mailman?

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list