[Mailman-Users] turn on tracing?

Richard Shetron guest2 at sgeinc.com
Fri May 20 14:22:56 EDT 2016

How do I find out what uid:gid the programs are running with?
Would I be better downloading a fresh copy of mailman and doing a 
reinstall over the broken copy?  The initial version was installed back 
in ubuntu 8.04 days when mailman wasn't a ubuntu package.  Since then 
for Ubuntu they changed some of the default groups for things, like 
mailing lists.

On 5/20/2016 11:47 AM, Mark Sapiro wrote:
> On 05/20/2016 05:35 AM, Richard Shetron wrote:
>> How do I turn on tracing to find the source of this error.  The
>> interface worked until I told check_perms to fix permissions so I'm sure
>> there is a permission issue.  Also the qrunner won't run, which I also
>> suspect is a permission error.  My partner who did the install has
>> retired for medical reasons so I'm trying to learn how to do all sorts
>> of things in too little time :(  I tried to look in both the mailman
>> logs and the apache logs for errors and didn't find anything.
>> Bug in Mailman version 2.1.21rc2
>> We're sorry, we hit a bug!
> There should be a traceback and other information about this error in
> Mailman's error log. If it's not there, there is probably a permission
> issue in writing the log.
> You can at least temporarily ensure that Mailman's logs are writable by
> anyone and see if that helps.
> Also, you can edit $prefix/scripts/driver and at line 33 set
> and the traceback will be included on the "we hit a bug" page.
> Also, if check_perms -f broke things, permissions must have been set in
> some non-standard way to begin with. See the FAQ article at
> <https://wiki.list.org/x/4030645>.

More information about the Mailman-Users mailing list