[Mailman-Users] Upgrading mm 2.1.26 on Ubuntu 18.04 to 2.1.29

Fabian Aldo Santiago fsantiago at gjb-online.com
Tue May 21 20:20:54 EDT 2019

Hello all,

I have my postfix mail server running mm 2.1.26 installed via apt on Ubuntu 18.04. I wish to upgrade to 2.1.29 but it’s not in the official repos. 

I tried installing from source, after first running mailman-config to gather the configure parameters (thanks Lindsay!). It installed no sweat BUT failed to start afterwards. It kept complaining of a pid file being unreadable. 

So I started over (restored snapshot) and then tried adding a ppa apt source which contains 2.1.29:


Installed with an IO error over a lock file purported to be from one of my lists but otherwise started ok. But sending an email produced an error complaining:

The mail system

<list at localhost>: Command died with status 2: "/var/lib/mailman/mail/mailman
 post list". Command output: Group mismatch error. Mailman expected the
 mail wrapper script to be executed as group "daemon", but the system's mail
 server executed the mail script as group "list". Try tweaking the mail
 server to run the script as group "daemon", or re-run configure, providing
 the command line option `--with-mail-gid=list'.

So that gid is what I used when I tried from source.

Does anyone have any ideas? Thanks. 


Fabian S.



Quick link to shared public key:

More information about the Mailman-Users mailing list