[Mailman-Users] Upgrading mm 2.1.26 on Ubuntu 18.04 to 2.1.29

Fabian A. Santiago fsantiago at gjb-online.com
Thu May 23 10:02:12 EDT 2019

On 5/23/19 9:04 AM, Fabian A. Santiago wrote:
> On 5/22/19 11:42 AM, Mark Sapiro wrote:
>> Did you look at <https://wiki.list.org/x/17891606>?
>> What was the exact complaint. It's probably easy to fix.
> Thank you Mark for this reference. I did not look at it. I also didn't
> record the error. i needed this server / list back up asap so i
> snapshot'ed the server 1st just in case and when i encountered the
> issue(s), i only had limited time to resolve or restore so i didn't
> spend too much time troubleshooting it. but i will try this as
> referenced in your link when i can afford more possible downtime and if
> the error reappears i will capture it.

ok, the issue occurred again with the same error. the complaint is (from
systemctl status ... -l):

May 23 09:44:40 mail systemd[1]: mailman.service: Can't open PID file

journalctl -xe reports:

May 23 09:46:02 mail CRON[18652]: pam_unix(cron:session): session closed
for user sogo
May 23 09:46:10 mail systemd[1]: mailman.service: Start operation timed
out. Terminating.
May 23 09:46:10 mail systemd[1]: mailman.service: Failed with result
May 23 09:46:10 mail systemd[1]: Failed to start Mailman Master Queue
-- Subject: Unit mailman.service has failed

there is no pid file present in that location. am i wrong in assuming
that gets created when the service starts?

the dir permissions in that path are:

root at mail:/var/run/mailman# ls -la
total 0
drwxr-xr-x  2 list list   40 May 23 09:41 .
drwxr-xr-x 38 root root 1260 May 23 09:06 ..

mm seems to start if i run "mailmanctl start", but not as the service.

i probably prefer to troubleshoot this issue and correct it rather than
use the ppa via apt. what say you? Thanks.


Fabian S.



More information about the Mailman-Users mailing list