<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=gb2312" http-equiv=Content-Type>
<META content="MSHTML 5.00.2314.1000" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#a6caf0>
<DIV><FONT size=2>
<DIV><FONT size=2>hello! </FONT></DIV>
<DIV><FONT size=2>&nbsp; I had installed openssl-0.9.6 and freeswan-1.5 
.</FONT></DIV>
<DIV><FONT size=2>The Makefile of pluto like this:</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=2>OPENSSLROOT=/usr/lib<BR>OPENSSLINCLS=<BR>OPENSSLLIBS= 
-lcrypto<BR>OPENSSLDEFS=-DOPENSSL</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=2>When I am compiling the freeswan-1.5 </FONT></DIV>
<DIV><FONT size=2>&nbsp; the error like this:</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=2>gcc -o pluto&nbsp; connections.o constants.o cookie.o crypto.o 
defs.o log.o state.o main.o server.o timer.o id.o ipsec_doi.o kernel.o 
kernel_comm.o demux.o packet.o<BR>preshared.o dnskey.o rnd.o spdb.o sha1.o md5.o 
gcryptfix.o g10_dsa.o elgamal.o primegen.o smallprime.o ../lib/libdes.a 
../lib/libgmp.a ../lib/libfreeswan.a openssl.o xmap.o xmap_file.o xmap_dir.o 
xmap_db.o xmap_ldap.o x_sobj.o -lresolv -lcrypto -L/usr/local/lib -lldap -llber 
-Wl,-rpath /usr/local/lib -L/usr/lib -ldb<BR>/usr/bin/ld: cannot open -lcrypto: 
No such file or directory<BR>collect2: ld returned 1 exit status<BR>make[1]: *** 
[pluto] Error 1</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=2>can help me to solve&nbsp; this question?</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=2>Thanks</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=2>Guoxing </FONT></DIV>
<DIV><FONT size=2></FONT>&nbsp;</DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=2></FONT>&nbsp;</DIV></FONT></DIV></BODY></HTML>