<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1">
<META content="MSHTML 5.50.4807.2300" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT face=Arial size=2>Bram,</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>Here's somethings I did...</FONT></DIV>
<DIV><FONT face=Arial size=2>1)&nbsp; Do the install 
--with-mail-gid=12.</FONT></DIV>
<DIV><FONT face=Arial size=2>2)&nbsp; make a link to 
/home/mailman/mail/wrapper&nbsp; in the /usr/adm/sm.bin directory.&nbsp; (at 
least that's where it was on mine).&nbsp; If a wrapper link exists, change the 
name of this one to something else.</FONT></DIV>
<DIV><FONT face=Arial size=2>3)&nbsp; Take the /home/mailman/mail info directory 
specifier out of the aliases file.&nbsp;Make the wrapper call match whatever the 
link in 2 is.&nbsp; No directory qualifier.</FONT></DIV>
<DIV><FONT face=Arial size=2>4)&nbsp; Run New Aliases.</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>After doing that...&nbsp; it finally did start 
working for me...&nbsp; </FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>--Will</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV>----- Original Message ----- </DIV>
<BLOCKQUOTE 
style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  <DIV 
  style="BACKGROUND: #e4e4e4; FONT: 10pt arial; font-color: black"><B>From:</B> 
  <A title=bram@nip.be href="mailto:bram@nip.be">[NIP] Bram</A> </DIV>
  <DIV style="FONT: 10pt arial"><B>To:</B> <A title=mailman-users@python.org 
  href="mailto:mailman-users@python.org">mailman-users@python.org</A> </DIV>
  <DIV style="FONT: 10pt arial"><B>Sent:</B> Wednesday, September 12, 2001 7:39 
  PM</DIV>
  <DIV style="FONT: 10pt arial"><B>Subject:</B> [Mailman-Users] GID</DIV>
  <DIV><BR></DIV>Hi,<BR><BR>I guess this question has been asked a lot, but I've 
  tried all the<BR>possible solutions I could find in the archive and none of 
  them fixed my<BR>problem. Every time the wrapper gets invoked from sendmail, 
  it returns<BR>this to the maillog:<BR><BR>---<BR>Sep 13 01:31:36 dell 
  sendmail[24530]: f8CNVaJ24530: from=&lt;***@***&gt;,<BR>size=1636, class=0, 
  nrcpts=1,<BR>msgid=&lt;<A 
  href="mailto:005d01c13be3$31a49850$0500000a@voyager">005d01c13be3$31a49850$0500000a@voyager</A>&gt;, 
  proto=ESMTP, daemon=MTA,<BR>relay=pop3.***.be [195.130.132.40]<BR>Sep 13 
  01:31:37 dell sendmail[24531]: 
  f8CNVaJ24530:<BR>to="|/home/mailman/mail/wrapper mailowner 
  nip-system",<BR>ctladdr=&lt;nip-system-admin@***.***&gt; (8/0), 
  delay=00:00:01,<BR>xdelay=00:00:01, mailer=prog, pri=30977, dsn=2.0.0, 
  stat=Sent<BR>---<BR><BR>So far, everything is okay. But, the mail never 
  arrived. So I thought,<BR>let's run "/home/mailman/mail/wrapper mailowner 
  nip-system" manually:<BR><BR>$ /home/mailman/mail/wrapper mailowner 
  nip-system<BR>Failure to exec script. WANTED gid 12, GOT gid 1012.&nbsp; 
  (Reconfigure to<BR>take 1012?)<BR><BR>Now I'm in doubt... I do a "make clean" 
  and then I configure with:<BR>- --with-mail-gid<BR>- 
  --with-cgi-gid<BR><BR>?<BR><BR>I've reconfigured about 20 times now and I 
  already got it to see "gid<BR>1012" (which is the group of the actual 
  wrapper), but now I'm a bit<BR>affraid to have to start all over again (and I 
  really mean: 'again').<BR><BR>So, what do I do next?<BR><BR>I'm logged in as 
  the mailman user on a Red Hat Linux system with<BR>Sendmail as MTA (shame on 
  me).<BR><BR>Thanks!<BR><BR>Bram<BR><A 
  href="http://brammeke.net">http://brammeke.net</A> .. ICQ 
  5960864<BR><BR><BR><BR></BLOCKQUOTE></BODY></HTML>