[Matplotlib-devel] supported python versions

Thomas Caswell tcaswell at gmail.com
Mon Sep 14 21:49:42 CEST 2015

Hey all,

I would like to propose the following for which version of python mpl
officially supports:

 - for v1.5 we continue to support 2.6, 2.7, 3.3-3.5
 - for v2.0 forward we support (2.7, 3.4, 3.5)

and allow for new, python3 only, features to be developed for mpl2.1
onward, so long as they do not break any existing functionality in py2.7.

We already support all of those versions on master, there is no good reason
to drop 2.6 support right before the RC.  For 2.0 we should drop 2.6 so
that we do not have to maintain a mpl2.0.x py2.6 compatible bug-fix branch.

Regarding dropping 2.6 as a supported version I suggest you read/watch the
following from Nick Coghlan:


We are resource limited and those resources would be better spent improving
the library and supporting modern version of python.  At some point it is
unreasonable for people running very old installations of python to expect
the the newest versions of down-stream tools to work.  If this is important
to someone, please step up to mange maintaining a 1.5.x bug-fix branch
which will maintain 2.6 compatibility.

Dropping 2.6 will also free us to being using OrderedDict and several other
language features added in 2.7.

Regarding dropping 3.3, every survey has shown that among the users who
have adopted py3, a vast majority are using the newest version so
supporting and testing against the older versions of 3 is not worth the

In all cases, versions of mpl that currently work on legacy versions of
python will continue to work.

Thanks to Eric, Mike, and Phil who have this a read over.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/matplotlib-devel/attachments/20150914/7585bdb0/attachment.html>

More information about the Matplotlib-devel mailing list